安阳开设赌场罪案例|澳门赌场百家乐有痹吗
?

绿盟科技

400-818-6868

安全研究

威胁通告
【威胁通告】多个Linux内核远程拒绝服务漏洞
综述
近日,Red Hat官方发布了一份安全公告,公告中指出了Linux内核中存在的多个基于TCP的远程拒绝服务漏洞。其中包括一个名为“SACK Panic”的高危漏洞和其他两个中危漏洞。

参考链接:
https://access.redhat.com/security/vulnerabilities/tcpsack

漏洞概述
CVE-2019-11477 SACK Panic
CVE-2019-11477称为“SACK Panic?#20445;?#26159;一个整型溢出漏洞,可由远程攻击者向?#36164;?#25915;击的系统发送一系列TCP选择性确认(SACK)包触发,这可能导致系统崩溃。成功利用此漏洞将导致受影响系?#25104;系?#25298;绝服务(DoS)。

  • 受影响版本:
Linux 内核版本 >= 2.6.29

  • ?#30740;?#22797;漏洞的稳定内核版本:
Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

解决方案:

可使用链接中检测脚本确定您的系统当前是否容?#36164;?#21040;此漏洞的攻击(https://access.redhat.com/security/vulnerabilities/tcpsack)

应用补丁程序:
PATCH_net_1_4.patch解决了Linux内核版本大于或等于2.6.29中的漏洞(https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_1_4.patch)。
?#36865;猓琇inux内核版本>= 4.14需要第二个补丁PATCH_net_1a.patch(https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_1a.patch)。

或禁用SACK(/proc/sys/net/ipv4/tcp_sack设置为0)

更多缓解措施详见:https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md



CVE-2019-11478 SACK Slowness 或过量资源消耗
CVE-2019-11478是一个过量的资源消耗漏洞,可以由远程攻击者向?#36164;?#25915;击的系统发送一系列TCP选择性确认(SACK)包触发,从而导致TCP重传队列的碎片化。?#36865;猓?#22312;4.15之前的Linux内核上,攻击者可能能够进一步利用分段队列,为后续针对同一TCP连接?#37038;?#30340;SACK导致昂贵的链表遍历,造成进一步碎片化,由此被称为“SACK Slowness”。成功利用此漏洞将严重阻碍系统性能,并可能导致DoS。

受影响版本:
  • SACK Slowness 影响版本小于 4.15 的Linux 内核

过量资源消耗影响全版本Linux 内核

?#30740;?#22797;漏洞的稳定内核版本:
  • Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

解决方案:

应用补丁程序 PATCH_net_2_4.patch(https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_2_4.patch)。

或禁用SACK(/proc/sys/net/ipv4/tcp_sack设置为0)

更多缓解措施详见:https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md

 

CVE-2019-11479
CVE-2019-11479是一个超额资源消耗漏洞,可以在远程攻击者为TCP连接设置?#31995;?#30340;最大段大小(MSS)时触发,从而导致?#36164;?#25915;击的系统利用额外的带宽和资源。利用此漏洞将导致受影响的系统以最大的资源消耗运行,影响系统性能。

受影响版本:
  • 影响全版本Linux 内核

?#30740;?#22797;漏洞的稳定内核版本:
  • Linux 内核版本4.4.182、4.9.182、4.14.127、4.19.52、5.1.11

解决方案:

应用补丁程序PATCH_net_3_4.patch(https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_3_4.patch)和PATCH_net_4_4.patch(https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001/PATCH_net_4_4.patch)。

更多缓解措施详见:https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-001.md


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有?#28304;?#23433;全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技?#24066;恚?#19981;得?#25105;?#20462;改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


关于绿盟科技
?#26412;?#31070;州绿盟信息安全科技股份有限公司(简称绿盟科技)成立于2000年4月,总部位于?#26412;?#22312;国内外设有30多个分支机构,为政府、运营商、金融、能源、互联网以及教育、医疗等行业用户,提供具有核心竞争力的安全产品及解决方案,帮助客户实现业务的安全顺畅运行。

基于多年的安全攻防研究,绿盟科技在网络及终端安全、互联网基础安全、合规及安全管理等领域,为客户提供入侵检测/防护、抗拒绝服务攻击、远程安全评估以及Web安全防护等产品以及专业安全服务。

?#26412;?#31070;州绿盟信息安全科技股份有限公司于2014年1月29日起在深圳证券交易所创业板上市,股票简称:绿盟科技,股票代码:300369。


浏?#26469;问?/strong>

关 闭
安阳开设赌场罪案例 云南十一选五遗漏统计 qq分分彩计划app 新疆风采喜乐彩开奖 百宝彩重庆百变王牌走 体彩山东十一选五走势图 内蒙古11选5走势图新 大庆冠通棋牌手机版本 苏宁云商股票 七乐彩走势图下载 江苏11选5基本走势图